Um alle Funktionen von Destinaja nutzen zu können, sollten Sie sich registrieren oder einloggen.
  • Hallo Zusammen,


    ich habe mich gestern auch ein bisschen mit dem Thema Datenschutz beschäftigt und für externe Bilder eine 2-Click-Lösung umgesetzt.


    Bei Betreten eines Gastes, wird diese unter dem Cookie-Hinweis gefragt, ob er externe Inhalte automatisch laden möchte. Stimmt er zu, wird ein Session-Cookie gesetzt und solange der Browser offen ist, laden die Bilder automatisch. Möchte er das nichts, wird kein Cookie gesetzt.


    Bei einem registrieren User gibt es in den Privatsphäre-Einstellungen eine Option um das automatische Laden mittels Cookie zu aktivieren.


    Entwickelt wurde das Plugin für WSC3.X


    Sollte euch etwas auffallen, so würde ich mich über eine Info freuen.


    Bitte denkt dran, es ist eine Beta-Version

  • Wenn ich das richtig verstanden habe, braucht es dann keinen Hinweis mehr in der Datenschutzerklärung, da der Benutzer ja selbst bestätigt, ob externe Bilder geladen werden sollen oder eben nicht. Richtig?


    Als Gast habe ich mir den Hinweis gerade angeschaut. Ist dieser Hinweis wirklich ausreichend?

    Möchtest du externe Inhalte (z.B. Bilder, Videos) auf dieser Seite automatisch laden?


    Bei den Antwortmöglichkeiten bin ich mir gerade noch nicht sicher.

    Nein, Danke oder Ja, Gerne


    Vielleicht würde das besser passen?

    Nein, ich möchte das nicht! oder Ja, externe Inhalte bitte automatisch laden!


    Klingt für mich etwas passender und klingt mehr wie eine Bestätigung. Aber ist zu lang oder?

  • Habe als Gast gerade weder akzeptiert noch abgelehnt, sondern bin einfach weiter gegangen. Youtube Videos werden z.B. weiterhin automatisch geladen... :/




    Bei Bildern sieht das Ganze so aus:



    Klicke ich drauf, reagiert Microsoft Edge nicht mehr und es kommt die Meldung, dass CompiWare nicht mehr reagiert... :/


    EDIT: Das gleiche passiert auch als angemeldeter User im Vivaldi Browser. Standardmäßig ist die Option in den Einstellungen deaktiviert. Klicke ich dann diesen großen Play-Button an, hängt sich auch Vivaldi auf. Ich muss den Tab schließen und die Seite neu öffnen.


    Aktiviere ich die Einstellung und rufe ein Thema auf, in dem Bilder angezeigt werden, hängt sich der Browser-Tab direkt auf. Das Thema wird nicht geladen.


    Habe die Beta erstmal wieder entfernt...

  • Hallo, danke für die Rückmeldung.


    Die Buttons würde ich möglichst klein lassen.

    Man könnte noch kurz erklären, was das externe laden bedeutet. Ich werde die Beschreibung noch mal erweitern.


    Wenn ich das richtig verstanden habe, braucht es dann keinen Hinweis mehr in der Datenschutzerklärung, da der Benutzer ja selbst bestätigt, ob externe Bilder geladen werden sollen oder eben nicht. Richtig?

    Ja, überall wo man dieses Prinzip hätte, bräuchte man das nicht.

    Youtube Videos werden z.B. weiterhin automatisch geladen.

    Bisher habe ich das nur für Bilder gemacht. Alles andere wären die Medienanbieter. Fällt dir sonst noch was ein, wo extern was geladen wird. (Bei AffiliateRewrite würde das nicht funktionieren, falls du daran gedacht hast.

    Klicke ich drauf, reagiert Microsoft Edge nicht mehr und es kommt die Meldung, dass CompiWare nicht mehr reagiert

    Das setzen und Abfragen des Cookies habe ich nur via Javascript gemacht. Ich werde das in die PHP-Datei verlagern und eine neue Beta hochladen. Vlt. Morgen schon...muss mal schauen...

  • Ja, überall wo man dieses Prinzip hätte, bräuchte man das nicht.

    Gut zu wissen. :)


    Bisher habe ich das nur für Bilder gemacht. Alles andere wären die Medienanbieter.

    Dann müsste die generelle Frage aber abgeändert werden, denn die lautet ja Möchtest du externe Inhalte (z.B. Bilder, Videos) auf dieser Seite automatisch laden? und da stehen explizit auch Videos mit dabei. ;)


    Fällt dir sonst noch was ein, wo extern was geladen wird.

    Eigentlich nicht... :/


    Das setzen und Abfragen des Cookies habe ich nur via Javascript gemacht. Ich werde das in die PHP-Datei verlagern und eine neue Beta hochladen.

    Ich bin gespannt... :)

  • Jetzt gibt es hier auch Neuigkeiten.


    Ich habe das Plugin in die Basisfunktionalität und die Erweiterung für die Bilder aufgeteilt.

    Dann kann ich das Basispaket zukünftig auch für meine Medienanbieter einsetzen.


    Es muss neu installiert werden.

    PoooMukkel : Kannst du mal testen, ob die Laufzeitabbrüche immer noch da sind. Auch die Beschreibungstexte für die Benutzerabfrage habe ich angepasst mit dem Hinweis "sofern technisch möglich". Dann vermisst keiner die Funktion bei z.B. Youtube. Die Standardanbieter müsste jeder selbst anpassen. Ich kann nur meine eigenen Anbieter ändern.

  • Sobald das hier fertig ist, mache ich mich wieder an die Medienanbieter.

    Beim Medienanbieter-Plugin kommt dann eine neue Klasse dazu. Sobald das Update gemacht wurde, muss man nur noch bei den Standardanbietern eine CSS-Klasse hinzufügen, bei der Quellangabe scr zu data-src ändern und zum Schluss eine neue Standard-Quellangabe scr für den Platzhalter dazu packen.


    Das hört sich schwieriger an als es ist. Ich werde dafür bestimmt eine Anleitung machen.

  • Ich habe mir das Plugin von Sascha gekauft und dafür muss ich das Verwenden externer Bilder im ACP deaktivieren. Muss ich das hier auch machen? Oder ist diese Einstellung eher egal?

  • Mit deinem neusten Klick and Load ist es zu einem Fehler gekommen.


    Was ist passiert?

    Leider ist es bei der Verarbeitung zu einem Fehler gekommen und die Ausführung wurde abgebrochen. Falls möglich, leiten Sie bitte den oben stehenden Fehlercode an den Administrator weiter.


    Administratoren können die vollständige Fehlermeldung mit Hilfe dieses Codes in der Administrationsoberfläche unter „Protokoll » Fehler“ einsehen. Zusätzlich wurden die Informationen in die Protokolldatei */log/2018-07-05.txt geschrieben und können beispielsweise mit Hilfe eines FTP-Programms abgerufen werden.


    Hinweis: Der Fehlercode wird zufällig generiert, erlaubt keinen Rückschluss auf die Ursache und ist daher für Dritte nutzlos.

    System Information

    • PHP Version:

      7.0.27-1~dotdeb+8.1

    • WoltLab Suite Core:

      3.1.4

    • Peak Memory Usage:

      10.167/256 MiB

    • Request URI:

      /wcf/

    • Referrer:
    • User Agent:

      Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36

    Error

    • Error Type:

      ParseError

    • Error Message:

      syntax error, unexpected ';'

    • File:

      */lib/system/event/listener/ClickAndLoadImgListener.class.php (16)

    • Stack Trace:
      • #0 */../../../../../../../[internal function] (?):
      • wcf\system\WCF::autoload('wcf\\system\\event\\listener\\ClickAndLoadImgListener')
      • #1 */../../../../../../../[internal function] (?):
      • spl_autoload_call('wcf\\system\\event\\listener\\ClickAndLoadImgListener')
      • #2 */lib/system/event/EventHandler.class.php (199):
      • class_exists('wcf\\system\\event\\listener\\ClickAndLoadImgListener')
      • #3 */lib/system/html/output/node/HtmlOutputNodeProcessor.class.php (80):
      • wcf\system\event\EventHandler->fireAction(wcf\system\html\output\node\HtmlOutputNodeProcessor, 'beforeProcess')
      • #4 */lib/system/html/output/HtmlOutputProcessor.class.php (51):
      • wcf\system\html\output\node\HtmlOutputNodeProcessor->process()
      • #5 */lib/data/shoutbox/message/ShoutboxMessage.class.php (75):
      • wcf\system\html\output\HtmlOutputProcessor->process('<p><img src="https://android-hubo.de/wcf/images/smilies/waswowie.gif" alt=":waswowie:" title="waswowie" class="smiley" height="70"></p>', 'de.revocode.wcf.shoutbox.message', null)
      • #6 */templates/compiled/28_wcf_1_boxShoutbox.php (172):
      • wcf\data\shoutbox\message\ShoutboxMessage->getFormattedMessage()
      • #7 */lib/system/template/TemplateEngine.class.php (321):
      • include('*/templates/compiled/28_wcf_1_boxShoutbox.php')
      • #8 */lib/system/template/TemplateEngine.class.php (549):
      • wcf\system\template\TemplateEngine->display('boxShoutbox', 'wcf', false)
      • #9 */lib/system/box/ShoutboxBoxController.class.php (98):
      • wcf\system\template\TemplateEngine->fetch('boxShoutbox', 'wcf', [ 7 items ], true)
      • #10 */lib/system/box/ShoutboxBoxController.class.php (63):
      • wcf\system\box\ShoutboxBoxController->getTemplate()
      • #11 */lib/system/box/ShoutboxBoxController.class.php (44):
      • wcf\system\box\ShoutboxBoxController->loadContent()
      • #12 */lib/data/box/Box.class.php (278):
      • wcf\system\box\ShoutboxBoxController->hasContent()
      • #13 */lib/data/box/Box.class.php (263):
      • wcf\data\box\Box->hasContent()
      • #14 */templates/compiled/28_wcf_1_cms.php (4279):
      • wcf\data\box\Box->render()
      • #15 */lib/system/template/TemplateEngine.class.php (321):
      • include('*/templates/compiled/28_wcf_1_cms.php')
      • #16 */lib/page/AbstractPage.class.php (323):
      • wcf\system\template\TemplateEngine->display('cms', 'wcf')
      • #17 */lib/page/AbstractPage.class.php (114):
      • wcf\page\AbstractPage->show()
      • #18 */lib/system/request/Request.class.php (83):
      • wcf\page\AbstractPage->__run()
      • #19 */lib/system/request/RequestHandler.class.php (96):
      • wcf\system\request\Request->execute()
      • #20 */index.php (9):
      • wcf\system\request\RequestHandler->handle('wcf')

    Nach der Deinstallation von Click and Load images ist der Fehler weg

  • Konnte bisher nicht wirklich testen, da ich in meiner Test Umgebung das Plugin von Sascha gerade auf Herz und Nieren prüfe. Möchte, dass es perfekt läuft, bevor ich es in meine Live Umgebung hole... Und aktuell sieht das mit der RC 3 gar nicht mal schlecht aus. :)

  • So, anbei das korrigierte Sub-Paket

    Da ist irgendwas von Viecode mit in der package.xml <!--<instruction type="script">acp/install_com.viecode.shop.php</instruction>-->

    Dann freue ich mich schon mal auf die Erweiterung für die Medienanbieter, für Bilder benötige ich diese Funktion nicht.

  • Hallo,


    kurzer Zwischenstand


    de.thewaiters.wsc.clickandload_31.07.2018.tar


    Es wird nun die Quelle angezeigt.

    Das Subplugin für die Bilder ist aus meiner Sicht fertig.

    Das Subplugin für die Medienanbieter könnte sich noch mal ändern, je nach dem was ich noch Anpassen muss. Ich gehe gerade die Medienanbieter durch.


    Für Youtube kann man das schon mal testen.

    In der Datei YouTubeBBCodeMediaProvider.class.php unter lib\system\bbcode\media\provider muss man diese Zeile

    Code
    1. return '<div class="videoContainer"><iframe src="https://www.youtube-nocookie.com/embed/' . $matches['ID'] . '?wmode=transparent' . ($start ? '&amp;start='.$start : '') . '" allowfullscreen></iframe></div>';

    gegen diese austauschen

    Code
    1. return '<div class="videoContainer clickandload"><iframe class="clickandload" src="https://www.youtube-nocookie.com/embed/' . $matches['ID'] . '?wmode=transparent' . ($start ? '&amp;start='.$start : '') . '" allowfullscreen></iframe></div>';

    Man muss hier einfach in die DIV und in das Iframe die Klasse clickandload hinzufügen. Die anderen Anbieter muss ich wie gesagt prüfen...